Install EC2 API AMI Tools in Ubuntu

ec2-api-tools and ec2-ami-tools are available in multiverse. The
multiverse component is not enabled in /etc/apt/sources.list by default in
the Ubuntu ec2 images.

There are 2 ways to get at these:

a) get (older) versions released with karmic by adding multiverse to
/etc/apt/sources.list:

$ sudo sed -i.dist 's,universe$,universe multiverse,' /etc/apt/sources.list
$ sudo apt-get update
$ sudo apt-get install ec2-api-tools ec2-ami-tools

b) add most recent versions backported to karmic:
Add the ppa https://launchpad.net/~ubuntu-on-ec2/+archive/ppa
Follow the instructions there, or:

$ sudo apt-get update && sudo apt-get install python-software-properties
$ sudo add-apt-repository ppa:ubuntu-on-ec2/ec2-tools
$ sudo apt-get update && sudo apt-get install ec2-api-tools ec2-ami-tools

That’s it. Enjoy your EC2 API Tools and EC2 AMI Tools in Ubuntu.